Lab Manual - OS2 Operating System
Principles

Unit OS2:
Operating System Principles

2.5. Lab Manual

Windows Operating System Internals - by David A. Solomon and Mark E. Russinovich with Andreas Polze

Roadmap for Section 2.5.
Lab experiments investigating:

® Process Execution

® Object Manager & Handles
© Interrupt Handling

® Memory Pools Labs

® System Threads

©® System Processes
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é Thread Activity with QuickSlice

# QuickSlice

FID Image Name

_Olx] e

% Process CPU Usage )

a SystemF rocess
2 Sy Stem

14 |smss.exe

18 |csrssexe

22 | winlogon.exe
28 | services.exe
Zb ||sass.exe

43 | spoolss.exe
23 |rpocss.exe

50 |topsvos.exe
58 | smmp.exe

Sc |tapisrv.exe
63 |nddeagrt.exe
G5 | pwrapp.exe
74 |rasman.exe
7d |explorer.exe
28 |inetinfo.exe
Qe |systray.exe
9f | gslice.exe

ad |mspaint.exe

IS 0

Fastest way to find CPU hogs
Red=Kernel, Blue=User mode

© Double-click on a process to

see a per-thread display for
that process

9  Sum of threads’ bars for a

process represents all of the
process’s time, not all CPU
time

# Q5hice - "explorer.exe’ _ O] x|
Processid P agedP ool MNonP agedP ool
70 oooo401B8 0o00oq 0E 0

TID Time fCE&

% of Process CPU - Total: 14%

Fo 000000000 SO
2d 000000000 SO
99 00o0oo0on 4O
oo 0000ab250 /2

Screen snapshot from:
Resource Kit | QuckSlice 4

é Process Info with Task Manager

@ Processes tab: List of
processes

E windows Task Manager

Image Mame
CPUSTRES.EXE
taskmar .exe
Acrobat.exe
POWERPNT.EXE
notepad.exe
calc.exe
cmd .exe
OUTLOOK.EXE
planner.exe
IEXPLORE.EXE
hh.exe
Metint.exe
TFNF5.exe
pinger.exe
vmnat.exe

File Options View Help

Applications | Processes | Performance | Networking

6 Applications tab: List of top

level visible windows

2 Windows Task Manager Q@@

File Options View Windows Help
Applications | Processes | Performance | Metworking
Task. Status
Microsoft PowerPoint - [dep353.ppt] Running
PID | CPU CPU Tin @" MindManager - [Troubleshooting Process &M... Running
3404 a5 0:00:1] BBl Command Prompt - robocopy jz \\edimgsrv1y... Running
2040 03 0:00:0 € Calendar - Microsoft Outlook Running
3608 o1 0=00: B command Frompt Running
3688 a0 0:05: (B} 1nbox - Microsoft Qutiook Running
: ': @Tasks - Microsoft Qutiook Running
ST (Y . 31 Reminder Running
M40 00 0:00: @ dep353.ppt Running
3396 iy] 0:00:
008 00 0:04:! “R N
2992 00 0:01: unning” means
2558 i} 0:05: 1t1 i
ool / waiting for window
21%6 nght-chckén a messages
1543 [ EndTask ][ switchTo | MewTask.. |

oz | window and select
“Go to process”

PU Usage: 2% Commit Charge: 187M [ 11
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- Process Details with Process
Explorer

@ “Super Task Manager”

® Shows full image path, command line, environment variables,
parent process, security access token, open handles, loaded DLLs
& mapped files

Process PID crPu Descripton Cremaor Session Ha*
Sl Gystem Idla Process o [ <access dented> 0 ]
4 o NT AUTHORITY..O A585
396 0 Windows NT Session Manager NT AUTHORITY. . O 2
462 0 i rver Runtime Process NT AUTHORITY. O 610
i) 1] Windows icatio NT AUTHORITY . O i
] 8He sz o ‘Windows Explorer DSOLOMONds... 0 679
EouTLODK EXE 1312 L Microsoft Outiook DSOLOMONds... 0 435
B e e 1980 0 Windows Command Processor DSOLOMONds,. 0 48
bk oxe 1316 0 i HTML Help E: DSOLOMONdSs,. 0 180
B procexp oxe 2932 0 Sysinternals Process Explorer DSOLOMONS... 0 67 »
< »
Handle Type ACCoES Name ]
Dne 34 Desktop 0x000F01 FF \Dafault
e Desktop 0x000F01FF Winlogon
(B4 Desktop 0x000F01FF \Disconnect
OxBE Desktop 0x000F01FF \Default
(01 4 Directory 0x000FO00F TWindows
D2 Directony De0002000F 1BaseNamedObjects
et Diractory 0x00000003 AKnown Dils
01 88 Event i Sta_D pS
1 AD Event 0x001FO003 Obyjercts went
01 BO Event 0x001FO003 1BaseNamedObjects\WFP_IDLE_TRIGGER -
< »
wrkogen. s o 476 Retush Rate: Pased

é The Process Explorer tool

Run Process Explorer & maximize window
Run Task Manager — click on Processes tab
Arrange windows so you can see both

P owdhpR

Notice process tree vs flat list in Task Manager
® |f parent has exited, process is left justified

o

Sort on first column (“Process”) and note tree view disappears

o

Sort Process column 2 more times and tree view returns

® Can also Click on View->Show Process Tree or press CTRL+T to
bring it back

7. Notice description and company name columns
8. Hover mouse over image name to see full path

9. Right click on a process and choose “Google”
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é Image Information

©® Double click on Explorer.exe to

bring up process properties

® Image tab:

e

o

o

Description, company name,
version (from .EXE)

Full image path

Command line used to start
process

Current directory

POWERPNT.EXE Properties 23
Image | Performance | Security | Environmer nt

Image File
Microsol t PowserPaint
Microsoft Corporation
Yersion 10.00.4205.0000
Path:
Ci\Program Files\Microsolt DfficetOffice] POWERPNT EXE |
Command ine
"C:\Program Flles\Miciosoft Dffice’ffice1 0\POWERPNT EXE™ |

Cunent directory:
syt

Paent  cmd exe(2716)
Owner.  DSOLOMONdavids

Stated  5E505PM 1/8/2003 il Erocesy

Parent process
User name
Start time

2 2 2 O

é Viewing the Process Tree

1. Look at process hierarchy with TLIST /T

@ Start a Windows command prompt, then run
Notepad from command prompt, then look at TLIST
/T output

® Exit the command prompt and notice “orphan”
process with TLIST /T

2. Task Manager:

@ Applications tab: find the process that owns a
window (right mouse click on window title)

® Process tab: add a few additional columns: Virtual
Memory size, Handle count, Thread count

® Windows: add I/O counters; right click on a process &
notice “end process tree” option
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Viewing the Base HALs

@ Windows 2000/XP/2003 HALs (see \windows\driver cache\i386\driver.cab)

Hal.dll Standard PC (uniprocessor)
Halacpi.dll ACPI PC (uniprocessor)
Halapic.dll APIC PC (uniprocessor)
Halaacpi.dll APIC ACPI PC (uniprocessor)
Halmps.dll Standard PC (multiprocessor)
Halmacpi.dll ACPI PC (multiprocessor)
Win2000 only:

Halborg.dll Silicon Graphics (multiprocessor)
WinXP only:

Halsp.dll Compag SystemPro (multiprocessor)

@ Additional NT4 HALs (see Knowledge Base article 156358)

Halast.dll AST Manhattan SMP

Halcbus.dll Corollary C-bus Architecture

Halmca.dll IBM PS/2 or other Micro Channel-based PC
halmpsm.dll Micro Channel Multi Processor PC
Halncr.dll NCR System 3000 Model 3360/3450/3550
Haloli.dll Olivetti LSX5030/40

Halwyse7.dll Wyse Series 7000i Model 740MP/760MP
Hal486c¢.dll Standard PC with C-Step i486

10

Determining Which HAL You're

Running
® Selected at installation time

@ See \windows\repair\setup.log to find out which one
@ Can seilect manually at boot time with /HAL= in

boot.in
Windows distribution Boot Partition:
CD-ROM:\i386 \windows\System32

NTOSKRNL.EXE;
NTKRNLPA.EXE,
NTKRNLMP.EXE,

NTKRPAMP.EXE NTOSKRNL.EXE

Windows Setup NTKRNLPA.EXE

HAL.DLL
HALACPIL.DLL
...etc.

HAL.DLL

(see \windows\repair\setup.log)
11
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E; Determine the HAL

@ Can also see by viewing the “device drivers” for the
Computer

® Go to Control Panel->System — Hardware_tah

Driver File Details 2

Click on “Device Manager”

ggvanced Configuration and Power Interface [CF1)

al dll
: krnlpa.exe
AWANNT S pstem32ntoskml exe

e
® Click on “Computer”
©® Right click/Properties on “driver” foyPC

[ oerice anager 1o
| action  wiew || 4= -o\m|@“

Pravider: Microsoft Corparation

File version: 5.00.2121.1
Advanced Configuration and Power InkstFace (ACPI) PC =l

T Coppright: ~ Copyright [C] Miciosoft Corp. 1981-1939

Screen snapshot from:

Control Panel | System | Hardware |
Device Manager | Computer properties |
Driver Details

12
*Tool: Dependency Walker (Depends.Exe in Resource Kit & Platform SDK)
«Allows viewing of image->DLL relationships, imports, and exports
&
NTOSKR N L ) EXE " Dependency Walker - [ntogkml] _[O]
©® Executive and Kernel 'ilﬁ“jdjew i iconlicb) o =181xl
= N W s e = ] B

@ HAL.DLL =] NTOSERHL EXE Ordinal ™ Hint [ Function B
. -1 [ @ n/a 0 [0:0000)  ExAcquisFastMutex -

e m ] NTOSKRMLEXE M8 1 [0=0001]  ExReleaseFasthdutes
6 Hardware AbStra‘Ctlon [l | ﬁDTV\D.DLL EN.J‘A 2 EUHUUU2} ExTryToAcquuteFalstMulex_l:'

Layer - interface to 8] NTOSKRNL EXE |4 | »

hardware platform BT haLDLL Oucinal~ | Hine [ Function =]
[E 1 (00001 O [0w0000) ExdequieFasttutes -

2 [0x0002; 1 [0<0001]  ExReleaseFastMutes
& BOOTVID.DLL % 3 {UMUUUB% 2 {UxUUUZ} ExTryTDAcquuteFatstMulex _';|

) ) 4] (ECIJ K | ’

® Boot video driver Module Time Stamp Size: Altibutes | Machine | Subspstem | &
] BOOTVIDDLL | 08/13/38 5:00a| 10.976| AC Intel 486 | Native |

i i ] HALDLL 0813/98 &:00a| B1.536|AC Intel 435 | Native
© Added in Win2000 I?II MTOSKRNLEXE | 08/13/98  8:00a i,zazssu ac Intel 486 | Native _'ILI
G KDCOM.DLL For Help, press F1 &

©® Kernel debugger

communication code
13
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Installed Device Drivers

©® Separate loadable modules (drivername.SYS)
© Linked like .EXEs
© Typically linked against NTOSKRNL.EXE and HAL.DLL

© Only one version of each driver binary for both uniprocessor (UP) and multiprocessor
(MP) systems...

B ... but drivers call routines in the kernel that behave differently for UP vs. MP Versions
© Defined in registry

© Same area as Windows services (t.b.d.) - differentiated by Type value
® Several types:

B “ordinary”, file system, NDIS miniport, SCSI miniport (linked against port drivers), bus
drivers

2 More information in /O subsystem section
© To view loaded drivers, run drivers.exe

B Also see list at end of output from pstat.exe — includes addresses of each driver
©® To view installed drivers:

© System properties->Hardware Tab->Device Manager

© Msinfo32->Software Environment->System Drivers
14

Peering into Undocumented
Interfaces

©® Exported symbols

® Functions and global variables Microsoft wants visible outside the
image (e.g. used by device drivers)

® About 1500 symbols exported
® Ways to list:
©® Dependency Walker (File->Save As)
© Visual C++ “link /dump /exports ntoskrnl.exe”

® Global symbols
©® Over 9000 global symbols in XP/Server 2003 (Windows NT 4.0 was
4700)
® Many variables contain values related to performance and memory
policies

® Ways to list:
® Visual C++: “dumpbin /symbols /all ntoskrnl.exe” (names only)
©® Kernel debugger: “x nt!*”

@ Module name of NTOSKRNL is “NT” .
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é Image Subsystem Type

® Look at subsystem startup information in registry
® Using EXETYPE, look at subsystem types for:

@ \windows\system32\notepad.exe, cmd.exe,
csrss.exe

16

é Viewing Open Handles

® Process Explorer (GUI version) or handle (character
cell version) from www.sysinternals.com

© Uses a device driver to walk handle table, so doesn’t need
Global Flag set

Hasdla | T | Accoss | Mama

030 Dasksop BOUFDIFF  \Delask

0218 Dimctory  Sx000F000F  \Windaws

0438 Duectory  B<000Z000F  \BaseMamedObjecs

0xC  Diectory  Sx00080003  \KnownDils

04164 Event BOIFO00T  WaseMamadObjeclsbesrmm: Usar Prof

114 Event E0IBO000  nseNamedObjecsloyptIZLogonE vant

17
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é Experiment with Handle-tool

Handle View
®  Suggestion: sort by type or path column
© Objects of type “File” and “Key” are most interesting for general troubleshooting
© By default, shows named objects
2  Click on Options->Show Unnamed Objects
® Solve file locked errors

©  Use the search feature to determine what process is holding a file or directory
open

@  Can even close an open files (be careful!)
® Understand resources used by an application
8  Files
&  Registry keys
® Detect handle leaks using refresh difference highlighting

@  Can also view the state of synchronization objects (mutexes, semaphores,
events)

18

é Maximum Number of Handles

1. Run Process Explorer, and click View and then
System Information. Open a command prompt.

2. Run the testlimit -h

*  When Testlimit fails to open a new handle, it will
display the total number of handles it was able to
create.

e If the number is less than approximately 16 million, you
are probably running out of paged pool before hitting
the theoretical per-process handle limit.

3. kill the testlimit process by closing the command-
prompt window; thus closing all the open handles.

19
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- Viewing Open Handles with

Kernel Debugger

@ If looking at a dump, use 'handle in Kernel

Debugger (see help for options)
Ikd> lhandle O f 9e8 file
processor number O

Searching for Process with Cid == 9e8
Searching for handles of type file

PROCESS 82ce72d0 Sessionld: 0 Cid: 09e8 Peb: 7ffdf000 ParentCid: O6ec
DirBase: 06602000 ObjectTable: e1c879c¢8 HandleCount: 430.

Image: POWERPNT.EXE

0280: Object: 82c5e230 GrantedAccess: 00120089

Object: 82c5e230 Type: (82fdde70) File
ObjectHeader: 82c5e218

HandleCount: 1 PointerCount: 1
Directory Object: 00000000 Name:

\slides\ntint\new\4-systemarchitecture.ppt {HarddiskVolumel}

é Troubleshooting a Pool Leak
® Run NotMyFault and select —

“Leak Pool”

(available from
http://www.sysinternals.com
[files/notmyfault.zip)

® Allocates paged pool buffers
and doesn’t free them

O® Stops leaking when you
select “Stop Leaking”

Fle Cptions  Yiew

Help

Applications | Processes

~CPU Lsage ——

Performance |

==

’—cpu Usage History ——————————————
age History —————————————

~Totals
Handles
Threads
Processe

a0l | | Total
423 | | Available
36 | | System Cache

Tatal
Limit
Peak

~Commit Charge (K,

)
132268 Total
149344 Paged
131868 honpaged

Processes: 36

CPU Lsage: 6%

Mem Usage: 132268K | 149344K VA

21
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Determining the Maximum Pool
Sizes

® Three options:

1.Poolmon (in Support Tools and Device
Driver Kit)

2.Kernel Debugger !'Poolused command
3.Driver Verifier (in Windows 2000 and later)

22

Mapping a System Thread to a
Device Driver

1. Generate network file access activity, for
example:
“dir \computername\c$ /s”

e System process should be consuming CPU
time

Open System process process properties
Go to Threads tab
Sort by CPU time and find thread(s) running

a bk N

Determine what driver these are in

23
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E; ldentifying System Threads in the
System Process

® To really understand what’s going on, must find
which driver a thread “belongs to”

® With standard user-mode tools:

1. PerfMon: monitor %Processor time for each thread in
System process & determine which thread(s) are
running

2. Pviewer: get “Start address” (address of thread
function) of running thread(s)

3. Pstat: find which driver thread start address falls in

> Look for what driver starts near the thread start address

24

é Solitaire as a Service

® Create a service to run Sol.exe

Sc create dumbservice binpath= c:\\windows\system32\sol.exe
©® Start the service

©® Use the GUI, or type “sc start dumbservice”, or “net start..”

® Quickly run Process Explorer and look at handle table
for sol.exe

©® Notice name of Windowstation object

® Open services.msc; mark service “Allow Service to
Interact with Desktop”

® Start the service again and in Process Explorer, look at
handle table for sol.exe

©® Notice name of Windowstation object

25
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Listing Installed Services

©® Not always a 1-to-1 mapping
® Some service processes contain more than one service

@ Conserves virtual memory, reduces boot time

©® This is up to the developer of the service

® Service properties displayed through Control Panel
(services.msc) show name of .EXE

© But not which process the services is running in

DHCP Client Properties (Local Computer)

General | Log DnI Hecoveryl Dependenciesl

Service name: Dhep

il

Digplay name:

Frescnption: M anage: k. configuration by registering and upds
Path to executable:

Dt R eSsstemareeTrites. exe

26

Viewing Service Details Inside

Service Processes

® Tlist /S (Debugging Tools) or Tasklist /svc (XP/2003) list
internal name of services inside service processes

® Process Explorer shows more: external display name

and description svchost.exe Properties @fzj

Image || Pedormance || Threads | Securty | Senvices | Envirorment

% Services registered in this process:

Service Display Name
| AudioSry __ Windows Audio |
|BITS Background Intelligent Transfe
|Browser Computer Browser
ECryplSvc Cryptographic Services
|Dhcp DHCP Client
|dmserver Logical Disk Manager
|ERSvc Error Reporting Service

< ¥

Manages audio devices for Windows-based programs. If this service is
stopped. audio devices and effects wil not function praperly. If this
service is disabled, any services that explictly depend an 1 wil fai to
start.

~

v

27
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. Viewing Services Running Inside

Processes

1. Open acommand prompt
Type “tasklist /svc”

3. Find the Svchost.exe process with the most services

inside it

4. In Process Explorer, double click on that Svchost.exe

process
5. Click on Services tab

6. Notice extra details about each service displayed by

Process Explorer

28

Service Configuration &
Control Tools

® To view & control services:

© Control Panel->Administrative Tools->Services

*hy Services

=10 x|

| action  vew |jﬁ-ﬁ|w|||§“ P oE I W

Tree I Mame  / | Description

| Skatus

| Startup Type | Log On As | ﬂ

Services (Local
are installation s

& Application Management

_I %DNS Client Resolves and caches Domain Mame Syst,..

-

%F\Iarter Motifies selected users and computers of ...

%ChpBoak Supports ClipBook Yiewer, which allows ..,
%COM+ Event System Provides automatic distribution of event...
%Computer Browser Maintains an up-to-date list of computer, ..
%DHCP Client Manages network configuration by regis...
%Dlstrlbuted Link Tracking Client Sends notifications of files moving betwe..

%Distrihnted Transaction Coordinator  Coordinates transactions that are distrib. ..

Started
Started
Started
Started

Started

Marual
Manual
Manual
Manual
Aukomnatic
Aukomatic
Aukomatic
Manual

Aukomatic

Local3ystem
LocalSystem
Local3ystem
LocalSystem
LocalSystem
LocalSystem
LocalSystem
LocalSystem
Localsystemn LI

® No option to add/remove — done at install/uninstall time

29




